Solana (SOL) Mainnet api 5xx response rate.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 17:22 CET
Investigating
We have detected an issue with Ledger services for blockchain Solana (SOL) Mainnet. This is being investigated by the team.
Posted Mar 15, 2024 - 17:20 CET
This incident affected: Ledger Explorers (Solana (SOL)).